欢迎来到博达网站群学习网!
设为首页 | 加入收藏
当前位置: 首页 >> 知识库 >> 部署类 >> 数据库 >> 正文

VSB连oracle用SYS用户报错

发布时间:2016-08-03    浏览次数:次

现象

在VSB后台的数据库连接池中配置连接oracle数据库时用SYS用户连接报错,错误为:

原因

Oracle数据库系统中SYS用户的权限很大,是不允许以普通用户角色连接的。。

解决方法

1. 在数据库连接的配置中一般不建议用SYS用户做为数据库连接用户的,就是因为它的权限太大。一般应建立一个普通用户给它赋相应的权限即可。

2. 如果非要使用SYS用户,那么必须给它指定以DBA的角色连接数据库,具体到VSB的连接池配置时,在用户名中填写“sys as sysdba”即可连接成功。