欢迎来到博达网站群学习网!
设为首页 | 加入收藏
当前位置: 首页 >> 知识库 >> 部署类 >> 应用服务 >> 正文

Rsync主机向备机同步数据报错问题处理

发布时间:2016-08-03    浏览次数:次

         

在客户端执行完同步数据命令提示

现象1:

@ERROR: chroot failed

rsync error: error starting client-server protocol (code 5) at main.c(1506) [receiver=3.0.7]

原因:

服务器端的目录不存在或无权限,创建目录并修正权限可解决问题(目录权限建议为755)。

现象2:

@ERROR: auth failed on module mediafile

rsync error: error starting client-server protocol (code 5) at main.c(1506) [receiver=3.0.7]

原因:

Client端已经设置/etc/rsync.pas这个文件,里面设置的密码为123456。和服务端一致,但是服务端的设置有错误,服务器端应该设置/etc/rsync.pas,但是文件的内容是root:123456。切记用户名不能省略。

现象3:

@ERROR: Unknown module ‘backup'

rsync error: error starting client-server protocol (code 5) at main.c(1506) [receiver=3.0.7]

原因:

服务器不存在指定模块。提供正确的模块名或在服务器端修改成你要的模块以解决问题。